Saturday 12th October 2024

Issue with Calling DID's hosted with Symbio from the Optus mobile network

Issue with calls to Vonex DID's hosted with Symbio from mobile voice services on the Optus mobile network on 12/10/2024 has been formally resolved with stable platform and calls since late 12/10/2024.